Integrations with IDEs, application servers and frameworks

JRebel comes with over 100 integrations. This means that you have instant reloads no matter what kind of changes you work with – code, resources or configuration. If you have found a use case we have not covered yet or if you are using a technology not listed here, feel free to shoot us an email at support@zeroturnaround.com.

IDEs

JRebel is provided as an IDE plugin bundle for each of the major IDEs. This bundle contains the JRebel agent itself and it integrates with the debugger. The plugin also makes it easy to configure JRebel and it helps with mapping the workspace to a running application.

IDE Versions
Eclipse 3.3 and newer
IntelliJ IDEA 11.x and newer
NetBeans 7.4.x and newer
MyEclipse 10.x and newer
Rational Application Developer 7.5.x and newer
Oracle JDeveloper 11g-R1 and newer

Application servers

JRebel integrates with application servers for Java EE support and in order to make sure that internal classloaders can see the changes you make.

Server Versions
Tomcat 4.x and newer
JBoss 3.x and newer
WildFly 8.x and newer
Jetty 5.x and newer
WebLogic 8.x and newer
WebSphere (Liberty Profile, Liberty Core) 6.x and newer
GlassFish 2.x and newer
TomEE Web/Plus 1.x and newer
Virgo for Tomcat 3.x and newer
Google AppEngine 1.x and newer
Liferay for Tomcat 6.x and newer
Geronimo for Tomcat 2.x and newer
Resin 3.x and newer
OC4J 9.x and newer
TCat 6.x and newer
vFabric tc Server 2.x and newer

Frameworks

Server Versions
ADF Faces with JSF 1 1.1.15.B1 or newer
ADF Faces with JSF 2 2.0.5-b02 or newer
Apache Taglibs 1.0.6 or newer
Axis2 1.6.2 or newer
Apache Camel 2.8.6 or newer
ATG  
CaptainCasa  
Classworlds 1.0 or newer
Click 2.2.0 or newer
Apache Cxf 2.0.6 or newer
DeltaSpike  
Ebean  
EclipseLink JPA 1.0.1 or newer
EclipseLink MOXy 2.5.2 or newer
JSF facelets 1.1.15.B1 or newer
Freemarker 2.3.16 or newer
Grails 2.3.2 or newer
Groovy 1.8.3 or newer
Guice 1.0 or newer
GWT 2.4.0 or newer
Smart GWT 2.5.0-rc2 or newer
Hibernate 3.3.2 or newer
Hibernate Validator 4.0.2.GA or newer
HK 2 2.1.92 or newer
iBatis 2.1.6 or newer
IceFaces 2.0.2 or newer
Jackson 1.1.2 or newer
Jenkins 1.532.3 or newer
Jersey 1.8 or newer
Jibx 1.2.3 or newer
JRuby  
LifeRay 6.0.6 or newer
Lift 2.1 or newer
Log4j 1.2.16 or newer
Log4j 2 2.0-beta4 or newer
Logback 0.9.12 or newer
Magnolia 5.1.2 or newer
Metro JAXB 2.0.5 or newer
Mojarra 1.2_04 or newer
Mustache 0.8.12 or newer
MyBatis 3.2.3 or newer
MyBatis-Spring 3.2.3 or newer
MyFaces 1.1.10 or newer
OpenJpa 1.1.0 or newer
OpenWebBeans 1.1.7 or newer
PicketLink 2.6.0 or newer
Prettyfaces 3.3.3 or newer
Reflections 0.9.9-RC1 or newer
RestEasy 2.0.1.GA or newer
RestEasy Jackson 2.0.1.GA or newer
Restlet 2.0.10 or newer
RichFaces 3.3.3 or newer
Scalate 1.5.3 or newer
Seam 2 2.0 or newer
Seam 3 3.1.0 or newer
Seam on JBoss 2.0.2.SP1 or newer
Seam on Jetty 2.0.2.SP1 or newer
Seam Wicket  
Seam Solder 3.1.1.Final or newer
Spring Bean 2.0 or newer
Spring Bean CDI 3.0.7 or newer
Spring Bean OSGI 2.5.6 or newer
Spring Bean Validation 3.0.7 or newer
Spring Boot 1.1.10 or newer
Spring Data JPA 1.2 or newer
Spring Data MongoDB 1.0.4 or newer
Spring Data Neo4j 1.2.1 or newer
Spring JAXWS 2.5.6 or newer
Spring JMS 3.1.4 or newer
Spring LTW 2.5.6 or newer
Spring MVC (XML) 2.0 or newer
Spring MVC (annotation) 3.1.4 or newer
Spring MVC OSGI 2.5.6 or newer
Spring ORM 3.2.11 or newer
Spring Portlet 2.5.6 or newer
Spring Security 2.0.8 or newer
Spring Tx 3.1.4 or newer
Spring Webflow 2.1.1 or newer
Spring WS 2.0.2 or newer
Stripes-Guice 3.1 or newer
Stripes with Spring 1.5.7 or newer
Stripes 1.5.7 or newer
Struts 1.0.2 or newer
Struts 2 2.0.14 or newer
Tapestry 4.1.6 or newer
ThyMeLeaf 2.0.15 or newer
Tiles 2.0.7 or newer
Struts Tiles 1.1 or newer
TopLink 1.0 or newer
TopLink JPA 1.0 or newer
Vaadin 6.8.2 or newer
Vaadin CDI 7.0.5 or newer
Webwork 2.2.6 or newer
Weld 1.0.1 or newer
Velocity 1.6.3 or newer
Wicket 6.3.0 or newer
Wicket-Spring 6.3.0 or newer
Wink 1.1.3 or newer
VRaptor Guice 3.4.1 or newer
VRaptor Pico Container 3.4.1 or newer
VRaptor Spring 3.4.1 or newer
ZK 6.0.1 or newer